News

RailModeller Pro 5.1.5 Fixes Printing Issue

2016-08-08 10:00

The latest update fixes an occasional issue where the app appears to hang for some users after creating a print out.

RailModeller Pro 5.1.5 is available on the Mac App Store.
Installed apps will be updated automatically by the built-in Software Update feature of OS X.


Maintenance Update RailModeller Pro 5.1.4 Released

2016-08-02 12:00

This maintenance update of RailModeller Pro fixes an issue for users running the app on Mac OS X 10.8 (Mountain Lion).
Please also note that starting with our next major update the minimum OS version required will be OS X Mavericks 10.9 or newer.

RailModeller Pro 5.1.4 is available on the Mac App Store.
Installed apps will be updated automatically by the built-in Software Update feature of OS X.


RailModeller Pro 5.1.3 featuring new clean up options

2016-07-20 08:00

The recent update 5.1.3 of RailModeller Pro features a new option to automatically convert manually bent flex tracks in the layout to straight or curved flex tracks with editable length or radius. The new "Move to layer" contextual menu command provides a quick way to move individual elements to a different layer directly from the layout area.

A number of additional improvements to the app's user interface allow quick access to previously used settings in a number of dialogs across the app.

RailModeller Pro 5.1.3 is available on the Mac App Store.
Installed apps will be updated automatically by the built-in Software Update feature of OS X.


Free track planning app "RailModeller Express" updated to Version 5.1

2016-06-29 09:00

The free RailModeller Express app for planning small model train and slot car layouts has been updated to version 5.1 now featuring support for marking sections of track as tunnel sections including the automatic creation of tunnel portals and layer defaults for color and track height. The latest update also features a range of improvements across the app as well as updated track libraries.

Please visit the product page for a comparison of our Express and Pro editions.

RailModeller Express 5.1 requires Mac OS X Mavericks (10.9) and is available for free through the Mac App Store in the Graphics and Design category.